点击这里更换您喜欢的皮肤wtboj 首页
请点击这里登入noios   首页 入门 c++讲义 入门教程视频 金牌教程 入门视频 站务 公告 | 题库 记录 竞测 测试 闯关 作业 排名 团队 讨论 | 换肤 | 登入 注册  
News >>   新增功能:各团队管理员可以发布本团队作业了 ()

From sina002
A+B Problem
背景 Background
  为了for beginngers,特设此题,^_^
描述 Description
  输入两个自然数,输出他们的和
输入格式 Input Format
  两个自然数x和y(0<=x,y<=32767)
输出格式 Output Format
  一个数,即x和y的和
样例输入 Sample Input
 
样例输出 Sample Output
 
时间限制 Time Limitation
  各个测试点1s
注释 Hint
  b]Free Pascal Code:
-------------------
var a,b:longint;
begin
 assign(input,'p1000.in');
 assign(output,'p1000.out');
 reset(input);
 rewrite(output);
 readln(a,b);
 writeln(a+b);
 close(input);
 close(output);
end.

C++ Code:
-------------------
#include <iostream>
#include <cstdio>
using namespace std;
int main(){  
 freopen("p1000.in","r",stdin);
 freopen("p1000.out","w",stdout);
 int a,b;  
 cin>>a>>b;  
 cout<<a+b<<endl;  
 fclose(stdin);  
 fclose(stdout);  
 return 0;
}
或者:
#include <iostream>
#include <iomanip>
#include <fstream>
using namespace std;
int main(){  
 ifstream cin;  
 ofstream cout;  
 cin.open("p1000.in");  
 cout.open("p1000.out");
 int a,b;  
 cin>>a>>b;  
 cout<<a+b<<endl;  
 cin.close();  
 cout.close();  
 return 0;
}


C Code:
-------------------
#include<stdio.h>
#include<stdlib.h>
int main(){
int a,b,c;
FILE *fin = fopen("P1000.in","r");
FILE *fout = fopen("P1000.out","w+");
fscanf(fin,"%d%d",&a,&b);
c=a+b;
fprintf(fout,"%d",c);
close(fin);
close(fout);
return 0;
}
Flag
  
题号
  P1000
  其它
通过
  385人
提交
  3253次
通过率
  12%
难度
  0
提交 讨论 题解
 Copyright wtboj © 2005-2006. www.wutuobang.date Powered by wtboj 关于 联系 帮助
 wtboj Information ---- Total Users : 1242 | Online Users / Processes : 0 / 46 | Processed Time : 31 ms | Server Time : 2025/4/26 21:07:20