点击这里更换您喜欢的皮肤wtboj 首页
请点击这里登入noios   首页 入门 c++讲义 入门教程视频 金牌教程 入门视频 站务 公告 | 题库 记录 竞测 测试 闯关 作业 排名 团队 讨论 | 换肤 | 登入 注册  
News >>   新增功能:各团队管理员可以发布本团队作业了 ()

From VijosGuest0
含有0的自然数
背景 Background
  为了for beginngers,特设此题,^_^
描述 Description
  一个数“含有0”是指这个数至少有某一位数字为0。小明对那些“含有0”的自然数很感兴趣,想挑出来进行研究。那么,1~N当中“含有0”的自然数有多少个?小明想在1秒钟内得到答案,你能帮他做到吗?
输入:N(1≤N≤100000000)
样例
  输入:105
  输出:15
输入格式 Input Format
  N(1≤N≤100000000)
输出格式 Output Format
  “含有0”的自然数的个数
样例输入 Sample Input
 
样例输出 Sample Output
 
时间限制 Time Limitation
  各个测试点1s
注释 Hint
  Free Pascal Code:
-------------------
program Plus;
var a,b:longint;
begin
 readln(a,b);
 writeln(a+b);
end.

C++ Code:
-------------------
#include <iostream>
using namespace std;
int main(){
 int a,b;
 cin>>a>>b;
 cout<<a+b<<endl;
 return 0;
}
Flag
  
题号
  P1065
  其它
通过
  33人
提交
  80次
通过率
  41%
难度
  0
提交 讨论 题解
 Copyright wtboj © 2005-2006. www.wutuobang.date Powered by wtboj 关于 联系 帮助
 wtboj Information ---- Total Users : 1242 | Online Users / Processes : 0 / 69 | Processed Time : 106 ms | Server Time : 2025/4/27 1:27:26