点击这里更换您喜欢的皮肤wtboj 首页
请点击这里登入noios   首页 入门 c++讲义 入门教程视频 金牌教程 入门视频 站务 公告 | 题库 记录 竞测 测试 闯关 作业 排名 团队 讨论 | 换肤 | 登入 注册  
News >>   新增功能:各团队管理员可以发布本团队作业了 ()

From VijosGuest0
删除数字
背景 Background
  为了for beginngers,特设此题,^_^
描述 Description
  输入一个长度为N的数字串,要求你删掉其中的K个数字,使得剩下的数最大。例如:数字串为5123, K=1时,如果删掉的数字分别是5、1、2、3,则剩下的数分别为123、523、513、512,其中523是最大的。
输入:第一行为两个整数N和K(1〈N≤100,0〈K〈N〉
   第二行是一个长度为N的数字串
输出:删掉K个数字之后剩下的最大数
样例:输入:4 1
      5123
   输出:523

输入格式 Input Format
  第一行为两个整数N和K(1〈N≤100,0〈K〈N〉
第二行是一个长度为N的数字串
输出格式 Output Format
  删掉K个数字之后剩下的最大数
样例输入 Sample Input
 
样例输出 Sample Output
 
时间限制 Time Limitation
  各个测试点1s
注释 Hint
  Free Pascal Code:
-------------------
program Plus;
var a,b:longint;
begin
 readln(a,b);
 writeln(a+b);
end.

C++ Code:
-------------------
#include <iostream>
using namespace std;
int main(){
 int a,b;
 cin>>a>>b;
 cout<<a+b<<endl;
 return 0;
}
Flag
  
题号
  P1069
  其它
通过
  43人
提交
  295次
通过率
  15%
难度
  0
提交 讨论 题解
 Copyright wtboj © 2005-2006. www.wutuobang.date Powered by wtboj 关于 联系 帮助
 wtboj Information ---- Total Users : 1242 | Online Users / Processes : 0 / 58 | Processed Time : 63 ms | Server Time : 2025/4/27 1:15:11