点击这里更换您喜欢的皮肤wtboj 首页
请点击这里登入noios   首页 入门 c++讲义 入门教程视频 金牌教程 入门视频 站务 公告 | 题库 记录 竞测 测试 闯关 作业 排名 团队 讨论 | 换肤 | 登入 注册  
News >>   新增功能:各团队管理员可以发布本团队作业了 ()

From VijosGuest0
前缀单词
背景 Background
  为了for beginngers,特设此题,^_^
描述 Description
  单词
【题目描述】
有n个单词和字符串T,按字典序输出以字符串T为前缀的所有单词。
输入:
第一行包含一个正整数n,接下来n行,每行一个单词,长度不超过20最后一行为字符串T.
输出
按字典序输出答案。
样例:
输入(words.in):
6
na
no
ki
ki
ka
ku
k

输出(words.out):
ka
ki
ki
ku
数据规模
60%,满足 1<=n〈=1000
100%,满足 1<=n〈=10000并且所有字母为小写



输入格式 Input Format
  第一行包含一个正整数n,接下来n行,每行一个单词,长度不超过20最后一行为字符串T.

输出格式 Output Format
  按字典序输出答案。
样例输入 Sample Input
 
样例输出 Sample Output
 
时间限制 Time Limitation
  各个测试点1s
注释 Hint
  Free Pascal Code:
-------------------
program Plus;
var a,b:longint;
begin
 readln(a,b);
 writeln(a+b);
end.

C++ Code:
-------------------
#include <iostream>
using namespace std;
int main(){
 int a,b;
 cin>>a>>b;
 cout<<a+b<<endl;
 return 0;
}
Flag
  
题号
  P1086
  其它
通过
  0人
提交
  3次
通过率
  0%
难度
  2
提交 讨论 题解
 Copyright wtboj © 2005-2006. www.wutuobang.date Powered by wtboj 关于 联系 帮助
 wtboj Information ---- Total Users : 1242 | Online Users / Processes : 0 / 59 | Processed Time : 80 ms | Server Time : 2025/4/27 1:15:12